FORUMS

Item Posts    Sort Order

ka24e idle problem

 
stihlayota
New User
Posts: 10
Joined: 12/10
Posted: 01/22/11 03:52 PM

my 95 hardbody just recently started acting up. cold mornings it would start fine but idle like it had a massive cam. pulling up to stop signs (engine warm or cold) the rpms would drop down to almost a stall n then back up to a grand - randomly. i hope i can get 2 more months outta it until i can pull it n go thro everything. Confused  

Post Reply
ReArAnGeD
User
Posts: 63
Joined: 01/11
Posted: 01/22/11 09:13 PM

check every vaccum line. clean your O2 censors but be very carefull when removing. the O2 censors may need to be replaced. check for any loose or naked wires. also have your alternator check. it may be slowly dying  

Post Reply
97nissanmike
New User
Posts: 2
Joined: 02/11
Posted: 02/22/11 06:29 PM

Mine is doing the same thing!!! The wiring is horrible on it and I put a second battery in it a shurikin and still its doing the same thing but it aso has 2 batteries and possibly a bad alterntor... please help me  

Post Reply
Mechman-Brian
New User
Posts: 7
Joined: 01/13
Posted: 01/23/13 07:55 AM

Check you IAC then check you mass air meter it may be dirty especially if you have a k&n air filter. Low vaoltage shouldnt cause an idle problem..But a low idle will cause a low voltage since the altternator is only a 60 amp unit  

Post Reply

BROWSE ARTICLES BY:

Subscribe Today and Save up to 83%!

Subscribe Truck Trend Magazine

Subscribe to:

Truck Trend
Magazine

PRINT DIGITAL
Subscribe Diesel Power Magazine

Subscribe to:

Diesel Power
Magazine

PRINT DIGITAL
Subscribe Truckin Magazine

Subscribe to:

Truckin
Magazine

PRINT DIGITAL
SUBSCRIBE TO A MAGAZINE
TO TOP